forums

TNT Basic Forums > Programming Q&A
Missing grass tiles
< Last Thread     Next Thread >
Author
Thread        Post A Reply

07-17-2003 17:41

Posted by:
Martin

Click Here to Email Martin   Find more posts by Martin

I used the code in the Outdoor Scrolling Demo to create my own sprites. Worked nicely but the grass tile didn't fill the whole canvas (?) map(?). My code was identical to the original and I copied the resources. And so I began looking around.

In the Map section of the Outdoor Scrolling Demo I opened the 128 - Untitled and then via Genesis accessed the Set Map Dimensions window. See below:

Map Width 40 (in tiles)
Map Height 30
Tile Width 32 (in pixels)
Tile Height 32
Tiles 5

Why are there just 5 tiles when there should be 1200? Or should there be?

And could that be why the grass was mowed?

Martin

07-17-2003 20:15

Posted by:
someone

Location:
Quebec ( Canada )

Click Here to Email someone   Find more posts by someone

Does it look OK in the map editor?

07-18-2003 10:17

Posted by:
Martin

Click Here to Email Martin   Find more posts by Martin

The editor window show a full lawn that I can scroll through using the side bars. I discovered something though: every time I run the program there's more grass; the fourth time I ran it a couple of tiles showed up in the middle where there were none. ???

Martin

07-18-2003 18:19

Posted by:
someone

Location:
Quebec ( Canada )

Click Here to Email someone   Find more posts by someone

Really strange... what kind of computer are you working with? Are you using hardware mode?

07-19-2003 09:18

Posted by:
Martin

Click Here to Email Martin   Find more posts by Martin

I'm using a G4 System 9.2.2. In good condition.
I don't understand what you mean when you refer to a "Hardware mode"?

Martin

07-19-2003 13:57

Posted by:
someone

Location:
Quebec ( Canada )

Click Here to Email someone   Find more posts by someone

There are 2 graphics modes: [ Graphics mode w,h ] and [ Graphics Hardware mode w,h ].

07-20-2003 10:26

Posted by:
Martin

Click Here to Email Martin   Find more posts by Martin

Thanks for the reference to the other (hardware) graphics mode but I solved the problem at least half way by correcting the color mask on the shadow of the tree. Now I have a full lawn with trees and shadows but the shadows don't know they belong near a tree - rather independent! I'm sure I will find the reason. Thanks.

I'm getting there.

Martin

All times are GMT        Post A Reply

Forum Jump:
< Last Thread     Next Thread >

< Contact Us - TNT Basic >

Powered by: vBulletin Lite Version 1.0.1 Lite
Copyright © Jelsoft Enterprises Limited 2000.