forums

TNT Basic Forums > Bugs!
iBook based temporary graphics slowdown?
< Last Thread     Next Thread >
Author
Thread        Post A Reply

09-19-2002 23:05

Posted by:
Franz Keller

Find more posts by Franz Keller

iBook based temporary graphics slowdown?

trying my new beta for the idev contest
www.franzkeller.com/whale/

and the graphics were noticably lagged...
But listen to this:
When i hit ESC and turned on the FPS counter,
the program started running at NORMAL SPEED?

tried it again, and always it runs slow,
until i turn on the FPS counter! Then runs fine.


heres the data:
iBook 500 white
Os 9.1?
TNT Basic Compiled App. (uses Hardware GFX mode)


BTW -
For some reason ever since ive used hardware mode,
the statement:
"set pen color white" produces BLUE ink?
It USED to work... weird.

09-25-2002 19:27

Posted by:
Franz

Find more posts by Franz

Any ideas? This could cause lots of trouble...

Any ideas? This could cause lots of trouble...

09-26-2002 07:39

Posted by:
John Treece-Birch

Find more posts by John Treece-Birch

Slowdown and weird colours

I've fixed the weird colours problem (white coming out as blue) in Hardware Mode so that will be included in the next release, however, I've been unable to reproduce the graphics slowdown bug.

I've downloaded your game (which is cool by the way, I really like the motion blur effect) and it seemed to run fine for me.

I've got an iBook but I've been using OS X so I'll look into trying it with 9.

Thanks,
John

09-26-2002 16:05

Posted by:
John Sadlier

Find more posts by John Sadlier

Os 9.1 is your problem - it sucks.

Upgrade to 9.2.2 and BAM! tough actin' tenactin'.

09-28-2002 07:19

Posted by:
Franz Keller

Find more posts by Franz Keller

John - Thanks. ;-) Viva hardware mode!

My code is really messy, though.

Will see if anything changes on my next few builds,
could be some kind of fluke.


I will probably just upgrade to Jaguar soon...
Have been waiting for my favorite apps to change over.


BTW -

The same TNT basic executable works on OSX and OS9, right?


09-28-2002 11:23

Posted by:
John Treece-Birch

Find more posts by John Treece-Birch

OS X

The same TNT Basic app runs under both 9 and X.

Upgrading to Jaguar will probably fix your slow graphics but TNT Basic doesn't work properly in software mode because something has changed between 10.1.x and 10.2. We're working on a fix which should be out soon hopefully.

Thanks,
John

09-29-2002 10:06

Posted by:
Mark Tully

Find more posts by Mark Tully

Graphics in software mode

We've just fixed the flickery graphics in software mode, expect a patch real soon.

Cheers,

Mark

10-03-2002 06:01

Posted by:
franz

Find more posts by franz

but now more trouble.


Build 101 of Mobius Whale Wars is out
www.franzkeller.com/whale/

but now more trouble.
framerate goes down to half (or even 1/4) normal...

(on my OS 9.1 iBook.
on the OS 9.2 PowerMac it runs great)
so i guess this trouble is caused by 9.1 ...

I guess ill just have to update that ibook...

All times are GMT        Post A Reply

Forum Jump:
< Last Thread     Next Thread >

< Contact Us - TNT Basic >

Powered by: vBulletin Lite Version 1.0.1 Lite
Copyright © Jelsoft Enterprises Limited 2000.