forums

TNT Basic Forums > Bugs!
A Small Problem You Really Need To Address!
< Last Thread     Next Thread >
Author
Thread        Post A Reply

04-25-2002 23:20

Posted by:
Douglas O'Brien

Find more posts by Douglas O'Brien

The problem that comes up in franz's post "a random fluke?" is happening kind of a lot to me. I happens when you draw sprites to a canvas, and draw the canvas to the screen through a view port (which I'm sure many games do).

Currently, I'm going to have to make my game so that it doesn't draw any sprites till they are completely (not particially) in the view ports area. The particials of sprites that get copied is when the problem happens.

04-28-2002 22:25

Posted by:
Mark Tully

Find more posts by Mark Tully

Priority Bug Fix

This bug will definitely be fixed in the next version.

It's happening because of a new optimised blitter that was put into 1.02. I fixed a bug in it for 1.03 but appear to have broken it in doing so :(

Sorry about that, I'll have it fixed and released very soon.

Cheers,

Mark

04-29-2002 00:21

Posted by:
Mark Tully

Find more posts by Mark Tully

Fixed

Just posted a patch to fix that bug, it was pretty quick to fix:

http://www.tntbasic.com/download/TNT_Basic_103M1_Patch.sit

Let me know if it works/doesn't work.

Thanks

Mark

All times are GMT        Post A Reply

Forum Jump:
< Last Thread     Next Thread >

< Contact Us - TNT Basic >

Powered by: vBulletin Lite Version 1.0.1 Lite
Copyright © Jelsoft Enterprises Limited 2000.